Wizzi Pages Error
Incident Report for Wizzi
Resolved
This incident has been resolved.
Posted Sep 04, 2019 - 15:45 UTC
Investigating
We are currently investigating an issue where hosting is down.
Posted Sep 04, 2019 - 15:27 UTC
This incident affected: Wizzi Client.